Custom shader not effected by scene light toggle

Hi,

I’m using a custom shader for the walls in my scene. I want it to be influenced by the scene light toggle for level-building purposes. Currently, the problem is when I turn the setting on:

202080-1.jpg

the areas 1 (with custom shader for the walls) and 2 (default sprit-lit shader) look like expected. But when I turn it off so that the scene light is not considered it looks like this

202079-1.jpg

How can I make my custom shader (shader graph) consider this toggle in scene view? I’m using 2D lights. Unfortunately, it seems I can’t upload more than 2 pictures to the question so I can’t add the graph.

Any help would be welcome.

I still dod not found a solution to this. Is there no way to include the editor light in the shader for 2D Lights?

The main problem is with 2D light as it will not have correct results for the editor scene light setting I guess but I also don’t find any information how scene light could be used in the shader.