Custom Skybox Seams

Using a standard spherical projection 360 pano image from Autodesk Stitcher (previously RealViz), I exported as cubic face images at 1024 pixels square. When setup in Unity as a new Skybox material, there are visible seams in the renderer. Careful and highly magnified views of the 6 images show nothing amiss on the edges at all... no darker or lighter pixels, no transparency, etc.

Is there a setting I'm missing in Unity? I have the render options set to "beautiful" with a good degree of anti-aliasing.

Here's an image (right click, view image for full size) alt text

You need to set each of your skybox texture's Wrap Mode to "Clamp". What you're seeing is a small amount of the opposite end of the same texture bleeding across due to the interpolation used in the texture's mipmaps.

To correct this, select the texture in your project view, then find the "Wrap Mode" setting in the inspector pane. It defaults to "repeat".

Thanks for this great advice, Duck. And thanks for asking the question, Dean. I've worked with skyboxes for a couple years in Second Life, and wanted to use that technology in Unity 3D. I was having the same problem with the seam lines, and that advice fixed things up great.

I wondered if you might know how to learn the process for making your own skybox images. I already purchased Cubic Converter software for the Mac. It works great in converting from different formats. And I've worked with Photoshop for nearly 20 years now. I've searched the web a lot to try and find a site that explains how to make the skybox images, but have not found a lot in that area. I want to design my own environment backgrounds for game levels.

Also if you happen to know of some good resources for royalty free skybox images, that would be great too. Here's one nice site that I found with some great skyboxes, but you're limited in using them for non-commercial use: -- free skybox tool. great for space scenes.

the only thing is my skybox (loaded from an example that came with the tool) doesn't wrap properly. you can very distinctly see the cute as a result. maybe something to do w/ the lighting i have setup in my scene?

I found this is still happening for me even with clamp wrapping if I have any compression on the texture. I want to keep my high quality resolution but if I don’t compress it the application crashes trying to load it if I do compress it there are seams visible. Any suggestions?

I encountered the same issue recently. I had to set Wrap mode to “Clamp” and turn off Mip Maps generation in the advanced settings.

@WelchCompositions @duck