Damped Transform applying position offset when set to zero

Hey, I'm using version 1.1.1 of the package, recently updated from 1.0.3 where I was still having the same issue.

I'm using a collection of damped transforms on a snake-like creature. I have damp position set to 0, and rotation set to 0.01 for each of the components. However, there is still a position offset between the bones, causing the mesh to split, which is much more visible when extreme position/rotation differences are taking place as well. This occurs even when they is no authored animation playing, just with the damped transforms.

Video: https://puu.sh/IuYU4/b0ed9f0fea.mp4

I'd appreciate any clues on how I can go about fixing this, thanks!

1 Like

I'm getting similar result with a similar set- up. It seems like even if the position is damped, there is some translation coming through causing the bones to stretch away from each other. I've tried different set-ups, but I still get stretching between the joints. Maybe it's a bug?

Also getting this issue

I'm having this issue too. Is there a fix to this problem?