Default Animation Show In Scene Editor

I am creating an a first person game, using Blender for the modeling and animating. The issues I am having revolve around what animation, or pose, is displayed in Unity’s scene editor. For example, I just created a running animation, where the character is holding a 2 handed gun. The gun itself is a separate game Object, that I parent to the player and then position it according to the hand’s position. This has worked so far, but now I cannot position the hand correctly( easily) because the default pose of the model in the scene editor is not the pose where the arms are outstretched to hold the weapon. It is in the middle of another animation that makes it almost impossible to position the gun correctly, because the rotation is different. Is there a way to set what animation shows as the default in the scene view, and possibly what frame in that animation is showing? This would make the process far easier.

I have tried searching for an answer, but it doesn’t seem to be a common problem so maybe there is just something simple I am missing. I appreciate your time and any help.


the default animation and frame you’ll get in Unity are the same animation and frame pose active while exporting the model from blender, so before to export the model you need to set the animation and frame you want to see in Unity as default. Otherwise, and this is the approach I use, just keep animations and models separated and export the model with the Baked animation flag unchecked.