Deferred Lighting Rendering

When I set the rendering to Deferred Lighting, I get some issues with black flickering with shadows.

Picture

Picture

The black will flicker, and it just doesn’t look good. Does anyone have any idea why this is happening? I really would love the option for deferred lighting for Soft Particles.

Fixed. It was due to floating point precision issues. The area must be within 0-1,500 or around there or else shadows will flicker a lot.