Deferred rendering and reflection probes

Hi, since I’ve started working with Screen Space Reflection I was forced to use deferred rendering. Now I encountered a problem with reflection probes of second floor (pink gizmos showing projection bounds) that affect roof mesh from bottom. Anchor Override don’t work. I need to find workaround to fix this ugly
reflections.

Only solution I’ve found so far is to force Forward rendering on those objects, which allows the Anchor Override (probeAnchor) to work correctly. You then place a ReflectionProbe in the center of the house, have it cull the house, and set that probe as the Anchor Override.

To force Forward rendering, I used a simple ASE shader, but there other other ways which you can search for here.

I know I’m really late to respond to this, but I’m pretty sure I’ve got the solution you’re looking for. I found it in this forum thread.

Go to Edit > Project Settings > Graphics, scroll down to Deferred Reflections and pick the “No Support” option. You might need to restart Unity in order for this setting to apply properly from what I’ve found.

Reflection probes should now behave like they would when using the forward rendering path on your project, but you should still be able to use screen space reflections.

Hopefully this solution works just as well for you as it did for me.