Detail mesh paint is not working!

Whenever i select a detail mesh for detail mesh paint on my terrain, and start painting, nothing happens! I Paint and nothing appears. I have checked detail mesh settings, and they are all as they should be. I have seen other people with the same problem, so i know its a real bug. How do i fix it?

I’m using Unity 3.5.0f1 Pro

PS i am using an .obj file i created in blender and imported as an asset.

And please answer! I have already asked this question once, with no answers. So if you have just the slightest clue, do not hesitate to answer! Please ^^

This could be a variety of things, but I finally figured out what I was doing wrong.
If your importing detail objects from a DCC app, be sure your scale and orientation are correct. If you scale them up in Unity (in your prefab for example), that scale value wont be respected by the ‘paint detail’ feature. It was working for me, but painting thousands of ultra-tiny rocks somehwere i couldn’t see…

good way to debug is just create a new file, create terrain, and load 1 detail object. Use that as your test.

hope this helps,


I just ran into this problem. Just make sure the detail mesh you’re using doesn’t have a collider on the prefab. If there is a collider on the prefab for the detail mesh, you will not be able to paint it on the terrain. Remove any colliders, recreate the detail mesh in terrain portion of the inspector just to be overly cautious.

Update: Also it seems that if your detail mesh prefab uses a mesh renderer with more than one material element, that your detail mesh will not paint to the terrain.

I found the Solution …

just click on the terrain and in the inspector go to terrain settings and assign the material is messing just click on the material bare and search for "default terrain … " and click on it and it will work fine !

if you wan’t to donate (paypal) :” (: