detectCollisions doesn't exist for rigibody2D?

Hello,
I’m new to Unity, I’m trying to implement a kind of powerup that would turn the object into a “ghost” mode where it would avoid collision with anything.
The easiest way to do this I guess would be to turn detectCollisions= false for the rigibody.
The thing is, I’m ysing rigibody2D (for a 2D game) and for some reason this does not exist for rigibody2D only rigibody. Am I missing something? How can I go around this?

Thanks

I didn’t find out why Rigibody has the property “detectCollisions” and Rigibody2D doesn’t but one workaround that works for me is to disable the collider for the GamObject as in

capsuleCollider2D.enabled =false;