Developing for Android - Gradle Error / AndroidManifest - Resource 'drawable/app_banner' not found

I’ve tried for the last three days searching and trying different solutions to this issue and about to headbutt my laptop.

I took out the lines in the manifest, in various ways…taking out the whole line, taking out the @drawable/app_icon lines, replacing the @drawable with @mipmap, and yet still nothing or more related errors to the line:

<application android:theme = "@style/UnityThemeSelector" android:icon='@drawable/app_icon' android:label='@string/app_name' android:isGame='true' android:banner='@drawable/app_banner'>


And a bunch more that I do not care to re-visit, but if you want I can list them here…later.

This started happening when I started to delete files that I no longer needed - is that what causes this mess? It’s been D L L hell.

How can I fix this other than what I’ve listed so far? I re-installed Android SDK’s, upgraded Unity (even though I’m in the middle of a project and usually that’s frowned upon and avoided like the plague)

  • I was grasping at straws at this point. My project is using two plugins, but had a third one which I removed (Would that be the cause?)


This is a bit older question but maybe it will help somebody. I encountered this problem after importing an Android related asset just to find out later that my previous Manifest.xml got replaced with a new one that contained the android:banner=‘@drawable/app_banner’. The SOLUTION for me was to jus t DELETE that “banner” part from the manifest. I am no professional or experienced Unity nor Android developer but I guess if you do not need the banner for something specificaly, then just remove it as it tries to look for the image associated with the banner that does not exist.

My lessons from this issue is to always double check what I am importing with each asset as it can cause unwanted ridiculous errors.137063-manifest.png

In case any juan else got stuck on this issue. After much trial and error and copious amounts of crying…

I deleted the Android Manifest.xml within the plugin/android folder. Restarted Unity and then ran the build. After a long wait of suspense the build was successful.

Did you solve this issue yet? Can you post your solution. Im struggling with the same thing.

So, after much wrestling with the build and the project…I honestly cant say what it was that did it. I edited the AndroidManifest.xml file, re-installed the Android Studio, upgraded Unity, adjusted my player settings and re-imported graphics that were originally used. Apparently, this is a hell-hole of an issue that requires many trial and error approaches…I still haven’t nailed down what caused it to go wonky. This is the second time its happened to me and each time was completely different errors in terms of the details but still under the “Gradle” / DLL issue.

If it does happen again, I’ll do the smart thing and write down each thing I did and post it here…hopefully, you’ve gotten yours solved by now? If not, definitely write down the steps you did and didnt do…

Has anyone figured out exactly what causes this error and how to fix it?
I’ve found that this is only an issue with Unity 2018.3, 2018.2 seems to build fine.