Did my software download incorrectly?

Hello all, Mooregrimm here,

I´m having beginner problems. I downloaded Unity 2018.3.5f1 (64-bit) and upon opening, it prompted me to download Unity 2018.3.6f1 (64-bit). However, while installing, it issued a promt saying that the install was stopped or failed because it couldn´t remove some of the previous files. I made sure everything was closed and clicked retry two times, but it was not succesful. so pushed run and it restarted the install. Afterwards everything seemed fine, except the old shortcut was still on my desktop, so I figurd at worst I´d have some redundant files to get rid of. Afterward, I started the Program,(2018.3.6f1) and ran the basic tutorials. Everything went fine until I got to Basic Tutorial - 03, step 5/14. After promting me to change the enimies speed value to 1, I did so, several times. By entering it manually as well as using the slide. I pressed enter aftarwards also. However, it doesn´t seem to register and make the “Next” button clickable. I´ve even tried exiting the tutorial, of course without saving, and restarting….same thing.

Any solutions would be greatly appreciated.

Thanks all,

-Mooregrimm

And if the file downloaded would have some transfer errors, it would not install. There are checksums in installers for situations like that.

reinstall 20183.3f1 as the other is still in a unstable experimental state. ignore the update warning and use 2018. 3.3f1 as it is the most recent stable version.

Update:

Found the issue on another post

1

Notes

Didn’t think of this but it makes so much sense. The name of the folder it is referencing is named wrong when installing into the older versions folder, renaming it fix’s the issue, although that would completely explain why I’ve never seen this error between unity 4.2 and 2018 - 3.3f1 i Always make a new folder, where most people just let it install wherever, i never do this for any program, always custom install, and there is a reason for this.

The Reason:

Reason is that the more data on you the slave drive read through, constantly has to read through it nlike a library of books, the slower you’re PC becomes, by never bogging down your C drive and allocation everything to their own folders, helps with you OS massively.

Thanks for the comments. So, i went to the Unity Download Archives and downloaded the 2018.3.3f1. Everything seemed to install fine, It said it was removing the old files as well. Afterwards, the old shortcuts were still on my desktop…so, again I figured I had some redundant files to get rid of. But, I started the 2018.3.3f1 anyways. I went straight to the Basic Tutorial - 03…same thing. Still not sure if it was just user error I exited and went to the Basic Tutorial - 04. Everything went fine until step 13/17. When asked to input the Transform values for the Pushable Box, the X value registers immediately. But, the Y value doesn’t register. It’s kind of a bummer, but I guess its not all bad, as long as the rest of the software works fine. But I would like to find a solution….I’m not sure if going through and making sure the other versions are deleted manually would help.
-Thanks