Directional light shadows not working

I’m using Unity Free 4.5.1f3 on a Surface Pro 2.

I can’t get shadows to work with directional light.

I tried building the exact scene on my MacBook Air (2011), and shadows work.

I’ve tried reinstalling Unity and creating a new project from scratch, but still no shadow.

Made sure Windows Update is up-to-date; no errors in Device Manager.

Did I miss something?

Windows 8.1, Surface Pro 2:

Mac OS X, MacBook Air 2011


Update 1

Back from resetting my Surface Pro 2 (using Windows 8’s reset).

Ran all windows updates, and installed Unity 4.5.1 before anything else.

Still does not work.

Dx11

Notice:

  1. Windows Update up-to-date
  2. Bare-minimum software installed

alt text

Dx9 (-force-d3d9)

alt text

OpenGl (-force-opengl)

alt text


Update 2

I’ve installed 4.5.2f1, but still no shadows.

Version 4.5.2f1 (9abb1b59b47c)


Update 3

Got confirmation from Unity that they were able to replicate the problem with a Surface Pro 2.

Have submitted a bug report.

Just for the record, I tried running another DirectX 11 shadow implementation and it worked. So the problem appears to be unique to Unity.

Update 4

It’s been a long time since I’ve submitted the bug request, but have not heard back from Unity.

Emailed the same Unity guy who contacted me, but never got a reply.

In the meantime, I managed to get myself a Surface Pro 3 (i7/512).

Installed Unity 4.5.5f1 on it, and still no shadows!

So here’s the score so far:

MacBook Air 2011/Surface Pro 1 = Shadows WORKS

Surface Pro 2 / Surface Pro 3 = Shadows NOT WORKING

So I thought, what the hell, let’s try it on Android

Installed on Nexus 5 = Shadows WORKS!

Tried on Galaxy S2 = Shadow WORKS!

Long story short:

  1. Unity behaves differently on different devices.
  2. Bug was confirmed by Unity; raised bug, but case was never updated, let alone fixed
  3. Further attempts to contact Unity = no response
  4. Tried changing IDE’s renderer; resulted in weird rendering issues (Dx9, OpenGL)
  5. Tried workaround suggestions of disabling Dx11
  6. Crashes Unity’s IDE completely (also raised bug, but no response)
  7. Subsequent attempts to start Unity = Crashes.
  8. Project file completely corrupted, had to delete project to even start up

I came across this bug when following the “Roll-a-Ball” tutorial, but never even got to the spinning cubes.

Many thanks to the community members who have tried to help.

But I’ve decided not to pursue this bug, nor Unity, any further.

under shadow quality setting change shadow distance to “in my case to 10000”.

Hey guys,

This issue is related to Intel HD graphics drivers. Surface PRO owners should be aware of that Microsoft releases tuned Intel HD drivers with a huge delay, after the latest drivers appear on Intel download center. That means, you simply can’t install drivers from Intel download center, need to wait for Microsoft tuned release. For the moment on Surface PRO tablets you can get Intel drivers version “10.18.10.3496” which seems fixes the problem with hard shadows issue.
Also, for Intel HD owners - try to keep your drivers updated :slight_smile: With release “15.33.30.64.3958 (10.18.10.3958)” Unity works fine.

Try Edir → Graphic Emulation (near the bottom) → No Emulation
Worked for me.

In my case, it was automatically changing quality settings from Fantastic to Fastest in build. So changed it again to Fantastic from script (Ex : QualitySettings.SetQualityLevel(5)). 5 is id for Fantastic.

Deleting all quality settings except Fantastic also resolves issue.

Hmm, try changing the type of shadow to hard shadow instead of soft if that doesent work, the surface pro unity may have some bugs or rendering issues

I’m not 100% sure how to fix it but you should check few thing just in case:

  1. Make sure your quality settings is set on max.
  2. Make sure you have shadows enabled under quality settings.
  3. Try changing soft shadows to hard shadows, because unity free doesn’t support soft shadows.
  4. Make sure that both the sphere and the plane can receive and cast shadows under Mesh Renderer settings.

Maybe you already tried all of them, but if you didn’t I hope it works :slight_smile:

Check quality settings - remove setting with no shadows, or change it. It help for me. Unity somehow could change to this option after build without permision.

I had same issue. Problem appeared after I build android version, so I build again pc version and shadows appeard again.
I use trail verison of Unity

I had this problem on Android for Unity on Windows.

Changing:

Edit → Graphic Emulation (near the bottom) → No Emulation

worked for me as well.

Yes you should try this
Edit → Graphic Emulation → No Emulation

i have the same problem, but when i reset the scale of all objects to 1:1:1 booom —> the shadows have occurred

It might not be your issue, but I had a huge game object in the scene that obscured all light. I only saw the object when I zoomed out a lot. Once I removed this object all shadows returned.