Disable "back" by mouse 4th button click in web-browser

I use 5-buttons mouse (as many others) and by default my 4th button is “back” and 5th is “forward” in web-browsers. So when I’m playing in Unity web-player I regularly (!) accidentally press that 4th mouse button that triggers “back” function of web-browser so I’m moved out of the game.

Is there any way to disable this in Unity?

No, there’s most likely no way since the Unity-webplayer plugin is “just” one small thing that’s running in the browser and isn’t allowed to “take over” a clients machine. If you want to prevent your browser from going back either:

  • open the webpage with the Unity player in a seperate tab without any history (press the 3rd mouse button on the link in FF)
  • or disable the back / forward function on your machine.

I would actually suggest the second solution since usually you should have the control of your PC.

(ps i use a 5-button-mouse as well, but i never ever have accidentally pressed the 4th or 5th button. Maybe your mouse design is not the best one… I use the new intelli explorer 3: p1 p2)