Disable Shadows

Im making an fps game but ive got an issue when im aiming my gun down and shoot the muzzle flash becomes darker does anyone knows how to disable the shadows i try not to receive shadows but it dont work.

Why not set the muzzle flash texture to an emission material, then it should look better and not be affected by shadow.