Disable touch left swipe on windows 10 and standalone build

I'm doing a standalone app for use on windows 10 and touchscreen The problem is that when i'm On fullscreen at application if you make a left swipe gesture windows shows task view and you can close app/ change app....

There is any way to disable this gestures by code or registry?

Thansk a lot

Ya I am working on unity Multi-display on Windows 10 with a HID Touch Screen Digitizer.

And Windows has Edge Gestures when a Unity Game is running. Very annoying.

Only thing I can think of is to place my HID TouchScreen into HID-Compatible mode and then maybe access the USB buffer directly in Unity. Since then windows does not know about the touch screen.

Windows really should have had a Settings option to disable gestures.

Hi @BrotenTechCorp

If you accomplish this change please let me know how you do.

My touchscreen is a PQlabs screen.

Try:

  • Open the Control Panel (icons view), and click/tap on the Mouse icon.
  • In Mouse Properties, click/tap on the Device Settings tab, and click/tap on the Settings button.
  • Check (enable) or uncheck (disable) the Enable Edge Swipes option, and click/tap on OK.
  • Click/tap OK in Mouse Properties.

Windows 10 does not always give this feature set.

If that does not work try:
http://winaero.com/comment.php?comment.news.103

This is for Windows 8 but some say it works on Windows 10 as well. Disable the Apps Switcher, and Charms Bar.

Read this as well:
http://appuals.com/disable-sticky-corners-edges-in-windows-10/

any other suggestions?

+1!

I'm also still looking to disable these "edge swipes" for a public facing fullscreen touchscreen application.

You can try device manager to disable touchscreen on windows 10.

  • Go to device manager
  • Now click on "Human Interface Devices"
  • Now click on "HID – Compliant Touch Screen"
  • Right click here and disable it.

Source: https://windowsclassroom.com/disable-touch-screen-windows-10/

https://winaero.com/blog/how-to-disable-touchscreen-edge-swipes-in-windows-10/

it's quite user unfriendly. i need to open registry editor to disable the swipe

i was using PQLabs and i could hide it by regedit.
CURRENT_USER>Software>Policies>Microsoft>Windows>EdgeUI>Create 32 bit DWORD>rename "AllowEdgeSwipe">Restart pc.

hope this helpfull.