Disable vsync in VR application

Hi,

I’m going in circles trying to find a way to disable vsync while using an HMD. I understand something has been done to take the ability to disable it from the developers and I’m not here to dabate it. But I do need to be able to overide it so I can control FPS in the application for an experiment that I have to conduct. As is I’m unable to disable that vsync even from the GPU settings (?!) or CLI when an oculus application using bare OpenVR is on.

So my question is this: how to disable vsync with a VR headset?
Alternatively: can I change the refresh rate on the HMD itself?

Did you ever figure this out? I’m having the opposite problem. I’ve enabled openvr but sonehow get fps in access of 245fps. I think the frame rate not being at an exact multiple of the hmd frame rate is causing judders.