Disabling the bouncing of particles when colliding + ignoring trigger colliders


I am quite new to Unity, especially to the particle system. I am currently in the process of making a particle system that could be enabled/disabled from a script, which goes fine.
The next step is to handle the particles collision with objects, more particularly with objects tagged as enemies. To do so, I defined in the collision editor the following parameters :

And the enemies have the following components attached :

Note that there are 2 colliders, one being a trigger (so that the AI can detect when something enters its attack zone and follow the target), the other being the collider of the body itself.

With this setup, I am currently facing 2 problems :

  1. When hitting the colliders, the particles bounces off. Dampen, Bounce and Lifetime loss are all at 0 in the collision editor, but it does not seem to prevent the boucing. I would like the particles to behave as if there was no collision (except that the OnParticleCollision should be triggered).

  2. I would like the particles to ignore the 2DCollider that behaves as a trigger, i.e., collisions should happen only with the smallest collider of my enemies objects. Is there a way for particles to ignore trigger colliders?

Hope this is explained well enough, thanks in advance for the answers !

You can ignore Trigger collision for Particle Systems (and Also Raycast) in 2 ways. You can put the trigger collider in a new empty object and set it’s layer to a custom. Than in Particle system collision settings ignore the costom layer or go to edit => project Settings => Physics2D (or Physics) => Uncheck Quaries Hit Trigger.