Display Resolution Dialog overwrites screen settings?

Im working in Unity version 4.3.4f1, and when I build a project, I use the following PlayerSetting:

Default is Fullscreen = false
Default Screen Width = 1920
Default Screen Height = 1080
Run in Background = true
Display Resolution Dialog = Disabled

When I build the exe and play it, the exe file is in fullscreen regardless if I set the seting:

Default is Fullscreen = true

But, if I change only this setting:

Display Resolution Dialog = Enabled

I build and play the exe, and I set the “windowed” option to true in the dialog.
Then I get the window mode as I want. But if I then change back the PlayerSetting to:

Display Resolution Dialog = Disabled

Then I always have window mode, eventhough I set:

Default is Fullscreen = true

Is this behaviour as it should be, or am I missing some kind of settings?
It seems that the Resolution Dialog is overwriting the Resolution settings.

Seems like to be a odd issue. I can only change from starting with either fullscreen or windowed, by enabling the Resolution dialog and change it there, and then go back and disable the dialog. As if the dialog always overwrite what I enable/disable in the PlayerSetting, regardless if the dialog is enabled or disabled.

I’ve also noticed that the exe file “remembers” if it was fullscreen or not the last time it was active. So if its fullscreen, I close the exe, and restart it, the exe starts in fullscreen. Can this be ignored? I would like to always start in window mode, eventhough I go to fullscreen later on manually.

Does anyone have any idea about this?

If anyone is curious about this, I asked in the forum and got a answer for it from user chechoggomez:

This is not an issue, the full screen mode is saved in the application registers

HKEY_CURRENT_USER ->Software->"“Company Name”->“Produc Name”

You will see :

Screenmanager Is Fullscreen mode

Screenmanager Resolution Height

Screenmanager Resolution Width


So this is why the application remembers if it’s Full screen mode or not.

So this is not a issue, but a setting from Unity. Read the whole post here: