.dll files will not be loaded in latest unity version

Every time when I want to start the game 5 directory erros pop up, which make the game unable to test in the Editor.
-Assembly ‘Library/ScriptAssemblies/Assembly-CSharp-firstpass.dll’ will not be loaded due to errors:
Reference has errors ‘Stores’.
-Assembly ‘Library/ScriptAssemblies/Assembly-CSharp.dll’ will not be loaded due to errors:
Reference has errors ‘Stores’.
-Assembly ‘Library/ScriptAssemblies/Assembly-CSharp-Editor-firstpass.dll’ will not be loaded due to errors:
Reference has errors ‘Assembly-CSharp-firstpass’.
-Assembly ‘Assets/Plugins/UnityPurchasing/Bin/Editor.dll’ will not be loaded due to errors:
Unable to resolve reference ‘UDP’. Is the assembly missing or incompatible with the current platform?
-Assembly ‘Assets/Plugins/UnityPurchasing/Bin/Stores.dll’ will not be loaded due to errors:
Unable to resolve reference ‘UDP’. Is the assembly missing or incompatible with the current platform?

Can you give me any help?

Same problem. Thank you, devs !

@unity_N2KDSek8n06ERA @binarybehemoth

Go to Assets\Plugins\UnityPurchasing and inside the folder you will find 3 packages 1.UDP 2.UnityChannel and 3.UnityIAP import these three to your project and your problem will be solved.

I have exactly same thing. Did you resolve it?

To anyone who experience the same error, it’s caused by unity in app purchase’s buggy installation package

  1. import custom package
  2. import UDP first, make sure the dialog window open, you may need to try a few times
  3. import the Unity IAP package

I just had the same error, the steps above solved it, you may need to restart the project a few times… good luck