DllNotFound when using PUN Voice on Mac, opus_egpv_dll

I was trying the demo project of PUN Voice. When running the demo scene, I keep having the following error message:

DllNotFoundException: opus_egpv
POpusCodec.Wrapper.opus_encoder_create (SamplingRate Fs, Channels channels, OpusApplicationType application) (at Assets/Plugins/POpusCodec/OpusWrapper.cs:124)
POpusCodec.OpusEncoder…ctor (SamplingRate inputSamplingRateHz, Channels numChannels, Int32 bitrate, OpusApplicationType applicationType, Delay encoderDelay) (at Assets/Plugins/POpusCodec/OpusEncoder.cs:227)
ExitGames.Client.Photon.Voice.LocalVoice…ctor (ExitGames.Client.Photon.Voice.Client client, Byte id, IAudioStream audioStream, System.Object userData, Int32 encoderSamplingRateHz, Int32 numChannels, Int32 bitrate, Int32 delay)
ExitGames.Client.Photon.Voice.Client.CreateLocalVoice (IAudioStream audioStream, ExitGames.Client.Photon.Voice.VoiceInfo voiceInfo) (at Assets/Plugins/PhotonVoiceApi/Client.cs:456)

I am using Unity 5.1.2, also tried in unity 5.3.4, same error. Operating system tried Yosemite and El Capitan. The demo project runs perfectly in windows.

opus_egpv.dll is in X86 and X86_64 folders under Plugins. I tried moving the dll file to root, asset, asset/plugins, none worked. Also tried to alter the file under Unity/Content/Mono/etc/config, still not working. Also tried to install Opus-tools and Opusfile from homebrew (I know this might be a long shot). Not working either.

Does anyone know what might be the problem? Thanks ahead!

Hi @TedZou.Try to copy Assets\Plugins\libopus_egpv.bundle\Contents\MacOS\libopus_egpv to the project folder to run the app on the editor. When deploy for mac check that demo.app\Contents\Frameworks\MonoEmbedRuntime\osx\ contains libopus_egpv

Hope it helps!