Does U3DXT support Unity 5?

Title pretty much says it all. Using the 5.0 beta and getting runtime errors on iOS, specifically:

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for U3DXT.iOS.Native.Foundation.NSUserDefaults ---> System.TypeInitializationException: An exception was thrown by the type initializer for U3DXT.iOS.Native.Internals._CoreExtrasInit ---> System.TypeInitializationException: An exception was thrown by the type initializer for U3DXT.Core.CoreXT ---> System.Exception: Exception of type 'System.Exception' was thrown.
  at U3DXT.Core.CoreXT._Init () [0x00000] in <filename unknown>:0 
  at U3DXT.Core.CoreXT..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at U3DXT.iOS.Native.Internals._CoreExtrasInit..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at U3DXT.iOS.Native.Foundation.NSUserDefaults..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at InitializationManager+<Start>c__Iterator19.MoveNext () [0x00000] in <filename unknown>:0

U3DXT does support Unity 5 however in Unity 5 you now have to manually select frameworks and platforms for each plugin. You can do so by clicking the plugin and in the inspector window checking off each framework and platform.

Hi, I had the same issue. In the iOS build settings I chose IL2CPP as the scripting backend and viola :slight_smile: Makes sense because since feb 2015 all the iOS apps must be x64 so IL2CPP all the way.