Does unity break every time you compile a project ?

seems every time i compile a project it finishes, and i get the exe, but then my unity and monodevelop are broken after that. saying dll stuff is missing, and saying that its unable to compile my code etc. that right before i created the exe worked just fine. any idea what im doing wrong, or how i can fix this? seems i have to completely re build my game and import the scripts etc to get a working version again i can continue to work with.

nevermind, it looks like it was breaking cus i was trying to compile and save it in my game project folder.

What version of Unity are you using (actual version identifier). What OS are you using?

This is not normal behaviour. I've used nearly every version of Unity over the past 2 years on both Windows 7 and OSX and have never seen such an issue.

The last time I saw someone mention something similar to what you're describing they returned to say it was being caused by a virus/trojan.

Edit: you beat me to it - ignore this post :)

thanks for the offering of help, appreciate it! :) that seemed to fix it as long as i never tried to build the exe or apk files etc. in the same game project folder. as soon as i stopped doing that it worked just fine. :)