Does Unity still require Android plugins to be compiled with JDK1.6?

From the docs:

Note: Unity expects Java plugins to be built using JDK v1.6. If you are using v1.7, you should include “-source 1.6 -target 1.6” in the command line options to the compiler.

Is this still the case? The lastest Java is now version 1.8.

Yes, it does.