Don't support specific devices (3G and below)

Is it possible to turn off support for 3G and below hardware? I noticed the new "Epic Citadel" demo did this, and would like to do it for our Unity game as we don't get acceptable frame rates for our style of game.

Basically when someone goes to purchase the app we'd like it to say "Your device is not supported" or similar.

(in-game)

Just check against IphoneGeneration. You can read more about it on these scripting reference pages:

http://unity3d.com/support/documentation/ScriptReference/30_search.html?q=iPhoneGeneration+

(on appstore)

Edit:

I think you should edit your info.plist

and specify your requirements using:

UIRequiredDeviceCapabilities

http://developer.apple.com/library/mac/#documentation/General/Reference/InfoPlistKeyReference/Articles/iPhoneOSKeys.html

well is there any matrix for these devices? if you try to filter iphone3g and the ipod touch out i have problemes determining what technical capability those devices inherit