ECS entity not rendering?

I have LocalToWorld and RenderMesh on the entity.
Entity shows up in debugger.
Hybrid Renderer installed.

My meshes just aren’t appearing.

        EntityManager entityManager = World.DefaultGameObjectInjectionWorld.EntityManager;
        Material material = GameHandler.instance.unitMaterial;
        Mesh mesh = GameHandler.instance.unitMesh;

        for ( int i = 0; i < NUMBER_OF_UNITS; i++ )
        {
            float3 unitPosition = new float3( 0 , 4 , 0 );

            Entity unit = entityManager.CreateEntity(
                typeof( RenderMesh ) ,
                typeof( LocalToWorld ) ,
                typeof( Translation ) );
            entityManager.SetSharedComponentData<RenderMesh>(
                unit ,
                new RenderMesh { mesh = mesh , material = material } );
            entityManager.SetComponentData<Translation>(
                unit , new Translation { Value = unitPosition } );
        }

I think we need some code example to answer you question. Have you added Translation Component?
So I tested your Script on unity 2019.3.4f1 and it didn’t worked to my big suprise, the script is totally correct, I even watched CodeMonkeys video where he shows the same code. I tested it then on Unity 2019.2 and it worked. So unity messed something up apperently or changed someting. I didnt noticed it bec I work with prefabs on which I then use the ConvertToEntity script. Some older scripts of mine also dont work and I dont know why :confused: