Editor crashes after loading a project

Everytime I start up Unity and try to open my project it loads everything, the editor flashes up and immediately closes again. At first deleting the projects Temp and Library folder solved the problem but after I restarted Unity it started crashing again. After consulting the log file:

Refresh: detecting if any assets need to be imported or removed ... Refresh: elapses 0.028450 seconds (Nothing changed)
- Starting compile Library/ScriptAssemblies/Assembly-CSharp-firstpass.dll
Receiving unhandled NULL exception
#0  0x007ffc25367000 in funlockfile

[...]

#28 0x007ffc25369950 in _start
Launching bug reporter
/home/builduser/buildslave/unity/build/Editor/Platform/Linux/UsbDevices.cpp:UsbDevicesQuery

[Unity Package Manager (Upm)] - Application terminated due to HTTP connection being closed on the other end.

Iv’e decided to delete the ‘Assembly-CSharp-firstpass.dll’ so it can recompile which has also only helped sometimes. All in all sometimes the fixes i’ve described help and the editor starts up fine but most of the time it still crashes.

I’m using Unity 2017.2.0 on Linux. The project was created with Unity 2017.1.0 and was converted to 2017.2.0 after which it worked fine for a few days before the errors started occurring. Older revisions of the project also work fine. The full log file can be found here.

Thank you in advance for your help.

Hi,
I also ran into that problem while running Unity 2017.2 on linux in a headless mode (batchmode/nographics).
It seems that this problem is very inconsistent (reproduces on some projects but not the other ones, does not reproduce on empty project).

In our case, running Unity through xvfb-run helped in most cases (but not in all cases).

Tak over at the Unity Forums helped me out with this. The problem was, that I’ve double clicked on the project in the home window. It seems like on a Linux platform you are only allowed to open the project with a single click. For me this fixed it. Here is the post on the Unity Forums.

I hope this’ll help you guys too!

This happens to me as well