Editor deletes Layout when pausing after maximise on play

For some reason, if I run my game in Maximise on Play, pause it, disable my UI and Player, unpause, then wait a bit, unity says it has to delete current layout and reset to default, after which I can continue (at which point it reverts the panel layout to the default state) or quit (the editor just closes). There is nothing in the profiler to indicate why this is happening, I get a consistent 200FPS and GC allocation never goes beyond 45 MB. This was just while not doing anything, so there were no scripts running apart from a shader graph shader.

I’m running Unity 2019.3.6f1 in 2D with URP, DX11. System is an Acer Predator Helios 300, Intel i5 8300H, Nvidia GeForce GTX 1050 Ti on Windows 10 home, version 10.0.18362 build 18362.

Any help is appreciated. As you can imagine, its annoying having to redo my layout every time I want to see how my shader looks

I have the same issue. I’m not doing anything complicated, just some modifications to the Karting Microgame. It happens randomly after exit the “Play” option in the editor, and reverts the layout to the default setting deleting the custom layout.
At least, please implement a way to save the layouts to disk, so we don’t lose them and have to manually modify everything again

Same problem. My saved layout is removed even so I can’t easily revert back.

Is there still no solution for this? still occuring till this day, and not in all of my projects. Some projects never got this bug, and some always have this bug.

Please help it’s driving me crazy to randomly close the unity and reset layout.,Is there still no solution for this? I still got this bug till this day

This is annoying, please fix this bug ASAP. It happens a lot lately, I am using version 2019 LTS

alt text


I recently ran into this issue in 2019.36
It wasn’t happening for our team before however with some current editor script changes the “Revert All Window Layouts” kept popping up everytime we maximized and then went back to default view.

The issue I identified was we had a method which inside OnEnable EditorWidnow script from a separate class which had “AssetDatabase.Refresh()”. Removing links to any refresh for the database on any of the init events on the Editor script resolved the issue for me.

Hope this helps someone :slight_smile: