Editor doesn't remember external script editor?

I set gvim to run my scripts with the arguments --remote-silent +$(Line) "$(File)" but everytime an assembly reload happens or I exit out/ enter Unity, it resets the script editor to be UnityVS.OpenFile - Same thing if I set it to MonoDev, doesn’t remember it either.

What am I missing? Is there something else I should do when setting the script editor?


(forums crosslink)

It seems that UnityVS overrides the setting. You can tell it not to do that by unchecking: Visual Studio Tools | Configurations | Open scripts with visual studio. That doesn’t mean you can’t use VS anymore, you could still open VS by going: Visual Studio Tools | Open in visual studio. It’s just that it won’t use VS for when you double click to open files or double click errors in the console.