Editor Hangs after first play using plugin DLL

Hi All!

So I have written some code in C# to wrap a C++ library and its API my C# wrap is a DLL and the C++ library is one DLL sitting in the plugin folder.

I have a problem where the Unity Editor is being really unstable. For example as long as I run the application within the Editor once, whenever I attempt to modify some C# scripts in the Unity project and return to the editor so it recompiles Unity Editor will just hang as not responding. I have to end the process and restart it. Same goes if I run the application once through the Editor and then decide to exit the Editor it will instead hang as not responding. Anyone know what’s going on here?

Any info at all here would be greatly appreciated.

I am properly cleaning up objects I have created in my managed and native sides.

I have replaced the contents of bin folder with http://indy.fulgan.com/SSL/openssl-0.9.8r-x64_86-win64-rev2.zip Then it worked for me.

Gord10?
and what has it to do with openssl, do you try to phish people?