Editor installation failed

OK, the computer is not very powerful, i5 without graphics card and SSD.
After about 3 hours of apparent progress, not supported by a percentage, in truth, with CPU at 100% constant and, in the last hour, the computer had become so slow as to be unusable, it says it failed
https://postimg.cc/vcMWd6CX (I would have liked to insert the image directly but could not: image toold don't work)

without specifying the reason.
Is there a solution to this?
What are (really) the minimum specifications?

do you solved it by now tell me pls

Really, no.

im sorry i have solved it see this

Hey it worked , i use version 2.4.5 hub from achieve, try using Idm if are facing downloading issues like me
It all works fine to download editor and sdks and stuff
But i ran into failed to update sdk again and again

https://forum.unity.com/threads/bug-verification-falied.1487886/#post-9272796

may this help

I'm not sure if we have the same problem: you talk about downloading the installer, I can't use the hub to install the editor. I think it is correctly downloaded. Anyway, where can I manually download the editor from without using the hub?
The SDK is a different problem, and I simply gave up on it if it doesn't do it on its own.

you can go here

https://unity.com/releases/editor/archive

in this page choose your version and clik relse notes on right side you will seemore options to download the Installer and along With Android build tools to make edioter work better

1 Like

After installing Unity Hub 3.5.1, I am unable to install a Unity Editor (LTS). The components download, but then the Editor application goes into a validation mode and executes for hours, but never completes, nor generates an error message. I cannot learn the product, if I cannot install it.

Bro you can install it manually like installling apps in windows by downloadling form website