Editor laggy and very slow


Only recently after updating to 2018 my Unity editor is unusable because it’s so slow and laggy, I’ve tried changing my DX11 to OpenGL and still nothing.

My PC specs are more than capable of running Unity at high FPS. But most of the time my editor will just lag out and feel like 2-3 FPS…

Anyone else having this issue in 2018 or old versions and anyone got some solutions?

Found cause of lag. Was Unity Collab

We have the exact same problem. We have to log out of unity to get it running smoothly again. Turning off collab alone isnt enough.

If we log back in with collab off its fine. Then if we turn it on and off again Unity it becomes unusable. Logging out is the only solution.

Logging out removes the lag for me.

Version 2018.2.0b3

Same problem here

Unity 2018.2.9 and 2018.2.10
If you have a MSI motherboard, or (as me) you have an MSI notebook, and you internet connection isn’t via cable, you can try to delete the lan drivers and/or lan software. It worked for me.

Still getting this problem.

Moving around the scene view seems like 10FPS.

I downloaded unity 2018.2
and I cannot make a promo video because of the quality of lag while playing the game in editor.
I hope theres a solution

is very easy to fix after some studies in the editor:

Go to lighting> settings and deselect the option:
auto generate>
Then go to the window.
Edit> Preferences> GICASHE>
Clean Cashe.
Ready can move on now.

for everyone using 2019.2.15f1 OR something similar:

  1. Dont move the game view to another monitor. if you have a second monitor and want the view (or anything else from unity) on that screen, dont do that.
  2. Close all Tabs like lightning settings, package manager, some other assets windows from plugins…

I think the the lightning setting are making huge problems if you let them open… could be also one of the other tabs i closed.

hope that helps

found a solution! just uninstall it and install UE

(for real now… Unity is getting worse with every update)