editor still drawing gizmos I've chosen to hide

Very little elaboration needed here. The scene and game views have dropdown menus which allow you to select which gizmos to draw based on the script they’re drawn from OR their factory-designated type. My scene and game views are ignoring my selection of which factory-designated types to hide, instead drawing all of these no matter what.

I uncheck lights / projectors from this menu, but the editor keeps right on drawing them when draw gizmos is selected. No scripts are drawing these, nor are any scripts allowed to draw gizmos in this menu. Also curious why I can’t uncheck particle systems in this menu, as having those grape-cluster icons flying about is very distracting when I don’t want to see them.

Thanks for any help. I must be missing something.

methinks you misplacing icons and gizmos

on this image red arrows show an icon. click on it in gizmos menu to disable/enable. green arrows points to gizmo, that show only if object is selected AND gizmo checkbox is selected too.

if this not what you are looking for, post a screen of your issue to explain what you are searching for.