error CS0117: `System.IO.File' does not contain a definition for `GetCreationTime'

Recently, I started getting the following error:

error CS0117: `System.IO.File' does not contain a definition for`GetCreationTime'

... when attempting to use that File's method. The weird thing is that it DID work at first, and suddenly stopped working (perhaps after quitting and re-opening unity, I don't remember for sure). The player settings are set at ".NET 2.0 Subset", but switching to ".NET 2.0" has no effect.

How could the mono library get downgraded like that? Looks like a bug to me.

Thanks for your attention!

I'm wondering if it stopped working after changing platform - it's possible that you originally had it set to PC/Mac, then changed it to Web Player or something else, meaning you got different mono libraries

Does your code look similar to this?

string path = "whatever";
System.DateTime dateTime = System.IO.File.GetCreationTime(path);

Because it works for me. Make sure you have proper arguments and that you're calling the method on the class. But I tried to break it in various ways, I can't seem to get the same error message. Do other file functions still work?