Error: GUI Window tries to begin rendering while something else has not finished rendering! Either y

I keep getting a compiling error when trying to use the pre made gui. I keep getting GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly. and some variation of
rc.right == m_GfxWindow->GetWidth() && rc.bottom == m_GfxWindow->GetHeight()
UnityEditor.HostView:OnGUI().
I am trying to use menus in my 3-D space is that not able to happen? Here is a picture in case you wanted to see. Note I've always gotten the VR warnings and that hasn't hurt any of my programs before.
Thank you for your help!

2670163--188408--Error.png

Hello,

This appears to be a noisy exception in the console log, sometimes it appears when you have more than one SDK active in your player settings. If it blocks you from building and launching your project can you please file a bug report.

Thank you,
Wesley

1 Like

I just installed 5.6.0p1 and now Im receiving this when never got it before.
I'm using iOS.

1 Like

I tried to repro using the installers for 5.6.0p1 and couldn't get this to trigger. Could someone that's seeing this file a bug report with a repro project so I can look into this?

I'm a one-man company, hard to stop work and do this as my project is very large. But I will say that at boot up everything is normal, but when I go to move a GameObject on screen, the error pops up 1 in 10 times. I dismiss it and everything is fine until the next time it pops up. If I ignore the error, nothing happens and everything works. But I usually have to be moving objects to get the error.

I'm encountering the same error and posted some more information on this thread:

https://forum.unity3d.com/threads/editor-error-spam-gui-window-tried-to-begin-rendering-assertion-failed-device-isinframe.465729/#post-3042001

From that thread:

So after setting Perforce logging to verbose, it seems that every time the Perforce fstat command is called, it's followed by the error mentioned above.

Together, it looks something like this:

fstat ".../Assets/.../Rock0.mat" ".../Assets/.../Rock0.mat.meta"
User xxxxxx ticket expires in 11 hours 8 minutes.
.../Assets/.../Rock0.mat
.../Assets/.../Rock0.mat.meta

GUI Window tried to begin rendering while something else had not finished rendering! Either you have a recursive OnGUI rendering, or the previous OnGUI did not clean up properly.

... additional spew ...

Im getting for all kinds of reasons. When I switch to one monitor focus to a 2nd monitor focus. I have my editor on 1 screen, and my game window on a 2nd (MAC) If I move an editor window, it triggers it, If I move a game object, it triggers it. But not 100% of the time, but maybe 75%.

I get this error after I've hit play in-editor, click out on another monitor, then click back back on Unity Editor. Soon as it resumes focus it throws this error.

Did someone log a bug on this and if so can you paste the bug link? I am getting the same result.

Same problems here. It just started after I updated an asset. In an attempt to isolate this problem, I commented all the OnGui code I could find in the respective asset. Still does it , and now throws exceptions constantly. Slows everything down so i can't run , can't test, can't do anything.

Unity 5.6 0f3.

Edit. After trying a bunch of different suggestions , nothing works. This seems completely random. I ran for 20 minutes with no problems, closed and reopened the editor and now it won't stop throwing those exceptions. I'm gonna die of a heart attack.

We are getting the same on this end. It seems there is an existing issue logged here:

https://issuetracker.unity3d.com/issues/perforce-built-in-perforce-vc-reports-ongui-error-when-opening-project-settings-windows

Feel free to flock and vote. :)

Our team has been on 5.6.0p4 for a few hours now without this issue occurring. It seems like it was fixed in 5.6.0p1:

  • (895453) - Editor: Fixed GUI related Asserts when connected to an active VCS provider.

@unity_andrewc In my case it happens every time I open Asset Store as a tab on the same pane as Scene and Game. I would get that error every time I switch from "Asset Store Front Page" to "Download Manager", and sometimes when scrolling through "Download Manager" section.

Unity Pro 5.6.0p4. macOS Sierra [Metal].


I get between 10 and 100 of these errors all day long doing all kinds of random triggers. Most of them come from changing focus on windows/tabs. I'm on the same setup as you. I've just got to ignore them now.

@artysta , do you have Asset Store tab (activated/visible or not) somewhere in your layout?

Yes it's grouped with the editor/animator group as it is by default.

You could try removing that tab. It fixes the issue for me.


I will try that, Im in the middle of downloading 5.6.1, see what that does :-)

So far after about 6 hours Using 5.6.1f1 and no longer keeping the Asset Store tab open (active or not) seems to have killed the errors. So I would agree it seem related to the Asset Store.
EDIT: If I open the Asset Store window/tab The error immediatly pops up.

I'm getting the same error whenever I access either the "Services" tab or the "Asset Store" tab in the Unity editor.

I've confirmed that if I hide both of those tabs, I no longer get the error.

3 Likes