Error Launching Unity Web Player (v 5.3.1p1 Personal)

Hey. I’m getting the error in the above screenshot whenever I try to play a new build of any project as a Web Player build in Firefox.

Error Launching Unity Web Player: Failed to decompress data for the AssetBundle ‘WebStartData’.

First off, the reason I’m still trying to make these builds is that nothing I’ve ever tried to build in Web GL has worked other than an empty scene, or one with a sprite.

Web builds that I made weeks or months ago are working. But any new builds of the same projects, new projects, or even Unity tutorial projects all throw this error and won’t play.

Using the Download Assistant I tried to see if I was missing any parts of Unity that should be required, but I don’t believe so. I’ve done clean re-installs of both the Editor and Web Player.

Does anybody know what’s happening? Is Web Player still supported? Because Web GL is still useless as far as my projects have ever been concerned.

Patch Releases
We are listening to our users who are demanding that we fix more bugs, and faster, with our ongoing patch build releases. Each patch build is a full release of the editor with all runtimes and contains a number of bug fixes.
Please be aware that you cannot build and release a Web Player game with a patch release, as the runtime will not be updated with patch versions.

Back to Unity 5.3.1f1 ~~ ~that’s all.