Error 'networking' does not exist in unityEditor.Experimental

I’m getting this error:

namespace name ‘Networking’ does not exist in the namespace ‘UnityEditor.Experimental’

more specifically it is being fired from this location:


And it is causing literally everything to stop working in unity. Please help SOS.

What I’ve tried so far:

  • un-install and re-install Visual studio (originally visual studio was
    broken now this).
    • un-install and re-install unity.
    • Delete csproj+sln in the project folder (per google search results).
    • Delete devenv.exe from program files (also per google search
    • Re-add devenv.exe to program files.
    • remove and re-add .vs folder from project folder (a personal
    • remove library folder and restart unity (this one took over 30 minutes
      to reboot, I was hoping it would fix
      the whole of the cache folder but no
    • comment out lines of code in MemoryProfilerWindow.cs that are
      causing error codes.
    • un-comment out those lines of code (as the result was a dizzying mass of
      new error codes).
    • google "fix MemoryProfilerWindow.cs (no dice).
    • Submit a help question…maybe go to bed and try again tommorrow…
  • Update: I went in to the package cache folder in the library and removed 8 folders, the result was the bug was gone and everything worked more or less the same as it used to…however when I returned to the project later on in the day…Unity reloaded the folders automatically in to the package cache folder and the error codes returned…

The folders that I removed were :

Current theory:

The problem may be being caused by a corrupted file, because I found a corrupted .config file in my visual studio program files.

I found the answer to my own problem…Yay!? I guess…

Help → Reset Package to defaults

Ah hah! Knowing exactly where the issue was coming from gave me a better direction for what to search online. The problem has been solved before, so I can not take full credit for figuring it out myself.

The original post with the answer is: Unity Issue Tracker - Errors appear when upgrading the project from 2018.2 to 2018.3

While everything isn’t quiet returned to working order it certainly solved the problem…only draw back being that it deleted most of my project settings…resulting in a lot of errors in regards to playerpreff’s but…I suppose if your already at the point were you are working with playerprefs, you are most likely also more than capable of sifting through and resetting things to be as they were…not the most fun way to spend an afternoon but much better than another day of digging through other peoples code trying to figure out what went wrong, making your entire project completely useless.

Happy coding friends!

-El Gatito The Bug Slayer (aka JT ) :stuck_out_tongue: