Error trying to build for android.

I recently did a full reinstall of windows and upgraded to win 10 and ever since when trying to build my game for android I’ve been getting the following error…

Error building Player: Win32Exception: ApplicationName=‘C:/Users/user_name/AppData/Local/Android/sdk\platform-tools\adb.exe’, CommandLine=‘devices’, CurrentDirectory=‘C:/Users/user_name/AppData/Local/Android/sdk’

I’ve Googled and came across a suggested fix of copying adb and its dll files from platform-tools to the tools folder but this didn’t work for me.

Does anyone have any other suggestions?


Go to unity-> preferences->external tools-> and here manual change the path of the android sdk…
here also check if the path is the same. And when installing sdk did you say install for all or just this user. and that you are sign in with that user if you have designated the install for user…

see full manual sdk install here:
link text

Try making sure if the directory to the SDK is right, it may be wrong and it is giving you that error that it can’t find the SDK. If that is not the problem then make sure you have your bundle identifier set to com.whateveryouwant.nameofgame .If you did’t set the identifier than go to file → Build Setting → Android → Player Setting than change the identifier. If none of these worked than your SDK may have a problem like maybe it is not updated or it failed to download a specific file. Go in and check that all the platforms you want to put your app on is checked and installed on your machine. If nothing works you can re download the sdk or find more help.

I hope this helped.

Worked for me: copy the android SDK folder directly to any root like C:\ or D:\ etc and then in Untiy>preferences>External Tools redirect your SDK to the new location