Error trying to open script with Monodevelop

I have been doing the beginners shooter tutorial.

I tried to open PlayerController script in Monodevelope via the Inspector open....

I get this error message :

unable to open assets/scripts/playerController.cs: check external application preferences

Monodevelop (built in) is application set in the preferences

Please how can I fix this?

Many Thanks

Perhaps, you didn’t installed monodevelop at the setup stage or you might moved it to the another location!

try reinstalling monodevelop again (don’t, if you have it in any other location) and then in unity
click on edit → Preferences → external tools → external tool editor

there you need to browse the monodevelop.exe file and then the error gets fixed.


Yeah… that’s weird. The file might be corrupted from the sounds of it, but this is a complete guess. Go to the Project panel and search for the script and single-click on it. If a code shows up in the Inspector, the file itself should be fine. If that’s the case, all I have else to say is rebooting (close and open) Unity and MonoDevelop and see if that improves anything.
Sorry if this wasn’t much help to you.

Thanks for your prompt replies.
This problem has stopped me completely in my tracks - was doing ok until this happened.
The script shows up fine in the Inspector - its when I try to open it from there the error occurs.
I`ve tried setting the preferences / External Tools to Monodevelop.
I have searched for the .exe file within the Unity folder although its not obvious which file to use.
I have tried opening .exe directly (outside of Unity) which i think may have been the correct file. The best I get is a Dos/console window flash up briefly then dissappear.

Any more ideas