Error: Unable to parse YAML file

After changing the editor serialization to “Force Text” every time I start Unity this error shows up once: “Unable to parse YAML file: [mapping values are not allowed in this context] at line 1”

This error can lead to broken scenes: e.g. misaligned transform positions or broken Font/Sprite atlases but it only occurs very randomly.

We are currently using Unity Version 5.1.1p2 but I also tried with other versions (5.1.3p3 and 5.2.0f3) with the same result.

We tried deleting the library so that Unity will show the exact YAML errors after restart but apparently there aren’t any.

We also went through all serialized YAML files with a custom script to check for invald YAML code but everything seems fine - except that the “stripped” keyword is not parseable by any YAML parser, obviously because it doesn’t match the YAML specification.
See here for more info about this:

We even tried deleting all scene files but the error still shows up. Changing the serialization back to “Mixed” doesn’t help either.

How can we fix this problem?

I’ve not tested. But you can try this [Fixed] Unable to parse YAML file in Unity 3d project

I don’t know if this problem is interesting for anyone. But I found another problem which can make a YAML parse error. There is a folder “Project settings” in any unity project. It has YAML files too with “.asset” extention and a “.txt” file with version. As in answer above it was a version control problem, but not in *.meta file! For me there was a problem in “ProjectVersion.txt” file.
Hope it helps anybody! :slight_smile: