error when i try to add any scripts

Hi, i had a functional unity project, and now, when i open the saved file, i have errors in all scripts in all objects. included some default scripts like the first person controler asset. I tried to erase the scripts and paste the code in a new one, but still having the same problem. Sorry for my english but is not my native language.

Image of errors

I tried to erase all the scripts and paste the code in a new script, but i still having the same problem. please i need help.

Try to reimport everything by right clicking anywhere and selecting it. If it doesn’t help try to check your project folder’s permissions (can the programs write to it?). The last suggestion is to reinstall unity. Also you can create new project and copy this project’s assets folder to the new project.

Ok, finally I found the problem… one of the scripts was corrupted when I saved it (I don’t know how), and it make me impossible access to the rest of the scripts.
Now, I am re-writing it, and all work fine.
Thank you very much for the answers