Error when opening VisionOS Template

I just tried downloading and opening the VisionOS Template with Unity Hub. I got this error:

An error occurred while resolving packages:

Project has invalid dependencies:

com.unity.ext.flatsharp: Access to ‘’ was denied

com.unity.polyspatial: Access to ‘’ was denied

com.unity.polyspatial.visionos: Access to '

If choose “Retry” it crashes and if I choose “Continue” it opens but has errors because the packages won’t resolve. Is there something else I need to do to get this to open properly?

Hi jtran–

This sounds like an entitlement issues. Can you check whether you’ve been assigned a seat, and whether you’re logged into the hub using the email address associated with that seat/entitlement?


Yeah, I have a seat and I have added those packages manually to my other project succesfully.

I actually got it working now by re-downloading the project and opening using the iOS build target instead of current platform. Not sure why I had that other issue. It’s working now

1 Like


I also get an error when opening the sample, forcing me to enter safe mode. When checking the PolySpatial package in the Package Manager it says : “Information is unavailable because the package license isn’t registered to your user account”.

What’s weird is that if I check my Organizations, I can see “Apple visionOS Beta” so I know I’m in :thinking:
I restarted my Mac (Silicon) and Unity Hub but still not working … Any help is welcomed

Try deleting that download and re-downloading the sample. Then also try opening it with iOS platform instead. You can change the platform to VisionOS after it opens properly. Not sure but that’s what worked for me.

1 Like

Thanks but when reading your posts that’s the first thing I tried and even after multiple attempts I keep getting an error when trying to access the packages :confused:

1 Like

Hi Dyfer –

I assume you’re talking about the “Apple visionOS Beta” subheading that you see if you go to the Organization via your profile icon at If so, try clicking on “Apple visionOS Beta” to see actual seat assignments. Under the “Manage seats” tab, find your user name and select it. Does either “Assign Seat” or “Revoke Seat” highlight when you do this? If the former, please try clicking “Assign Seat”, restart hub, and try again. Otherwise, let me know what you’re seeing and we can try to diagnose from there!


1 Like

Thank you Tim !

It seems I can’t access the “Manage Seats” section like I would on my other organizations

If I click on “See all” members I can find my name and email in the list as “User”.


Hey Ferdi, thanks for trying the above steps.
You might also need to make sure you’ve signed in on the account with the subscription in the Editor as well as Unity Hub.

I checked rechecked and rerechecked. I’m logged in with the correct email address on both the Hub and Editor →
Restarted the Hub, Editor and computer multiple times. Also deleted / redownloaded the sample multiple times. The same happen if I manually add the polyspatial package to an empty project.

Thank you Ferdi, hope the fix we worked on together has unblocked you!

1 Like

Working perfectly, thank you so much Isaacs !

hi @Dyfer - what was the solution in the end? Did you need to do anything outside what is listed in this thread?



Yes, Isaacs had to remove / re add me to the organization.

Hi @IsaacsUnity I’m experiencing the same problems as Dyfer. However, his solution doesn’t seem to be working in my case. Would you mind lending me a hand?

Also, @Dyfer what steps did you specifically take to remove and add yourself to the organization?

I couldn’t fix it myself. Isaacs had to remove and add me on his side

Thanks for the message. I’m looking into the issue for your account.

I just created a different topic because I didn’t see this one. I too am having issues with my account not having access to the packages anymore.


It seems to be fixed now. The license was assigned to me through the company I work for, but I redeemed it on my “personal” organization.

1 Like

I seem to have lost access again. It’s getting quite difficult to work with this now. Anyone that can help? @DanMillerU3D @IsaacsUnity

Can you email us at so we can help troubleshoot? Thanks!