" error while installing visual studio (error code:1603) " while installing unity 5.x pro

I am trying to install unity 5.x pro. But, there is an error popup saying “error while installing visual studio (error code:1603)”. I tried re-try option but that is of no help. Then I just ignored the message and the unity installation is finished. Can anyone explain me the cause of the error message and what are the necessary actions I should take to have smooth performance of unity.

Hello my friend. I am Chinese, you know, our English is not very good, maybe some expressions are not clear, I hope you can understand. Today I also encountered the same problem when installing unity3d. Although I don’t know the principle triggered by this problem, I have solved this problem. Let me talk about my method. Do not download the installation package directly from the Unity website. First open your vistual studio, click on the tool, then click on “Get Tools and Features”. Then a popup window will pop up. New interface (same as when we first installed the visual studio interface). Use game and unified under the game to find game development in the workload. Install this component and then reinstall the installation package of the unity official website upon completion. This problem will be solved. I hope that I can help you.
你好,我的朋友.我是一个中国人,你知道的,我们的英语不怎么样,可能有些表述不清楚希望你能够理解. 我在安装unity3d也遇到了同样的问题.虽然我不知道原理是什么,不过我已经解决了这个问题.下面谈一谈我的做法,不要直接在unity官网下载安装包.先打开你的vistual studio,点击工具,然后点击获取工具和功能,接下来会弹出一个新的界面(跟咱们第一次安装vistual studio的界面一样).在工作负载中找到移动与游戏下的使用unity的游戏开发 .安装这个组件,完成后再重新进行unity的安装.这个问题就解决了,希望能够我帮到你

Try Installing Visual Studios from VisualStudios.com

It might be a problem using the unity VS installer.

Since that error code is an MSI error code, please see microsofts description of that error. It simply means that the setup can’t access a certain file / folder because

  • the file / folder is still in use and therefore locked by the system. Make sure you close all other applications before you run the setup. Especially the webbrowser (in case of webplayer plugin installation) and any kind of Visual Studio application. Since the VS installer also installs some frameworks (C++,.NET, …) you shouldn’t run any other programs that rely on those.
  • the target file / folder is encrypted or otherwise protected
  • the setup has been started with insufficient privileges. Make sure you run the setup with administrator rights (right click–> run as administrator).

Probably not enough space on hard drive C, no matter where you actually install it, and unity installer dosn’t tell you that for some reason.

no solution found

i have windows 10; 64 bit, while installing unity 5.4, i got the same error. i skipped it , the software launched but there were problems in the interface display