Errors Cannot change albedo color. NullReferenceException

Hi,
I am new to unity and am taking a game development course in Coursera.
I am working with assets and scripts provided by the teacher and have not modified or written any scripts.
Everything till this step worked fine. But when I tried to create an animation in which the albedo color changes, I got these three errors.

  1. I cant change albedo color! It always reverts to the color shown.

  2. What does it mean? Cant seem to find anything about this warning online.

3.These errors show up when I try to record animation and change color.

Hello! I’m taking the same course and encountered the same problem.

I’m not sure why exactly this is happening, maybe someone more familiar with the Unity Editor can clarify.
The properties you are animating using the record button are supposed to be added to the animation automatically by the editor, but they aren’t.
If you click on the “Add Property” button, then find “Mesh Renderer.Material._Color”, you can add it manually.
Then the record button should allow you modify that property and add keyframes.
You can repeat this process to animate the Position.

HI!
I had the same issue, i was in Unity 5.2.2,
try with Unity 5.5.3

:smiley: