Errors during import of AudioClip

Hello people.

I've just installed Unity to version 2022.3.17 on MacOS 14.2.1 in a Mac mini 16 Gigabytes 1 tera with an M2 processor. Lots of free space and memory available. I import a project from version 2022.3.16 and tried 3 times, and I always get this error you can see below in 5 files.Example:

Errors during import of AudioClip Assets/Music/myfile.mp3:
FSBTool ERROR: Internal error from FMOD sub-system.
FSBTool ERROR: Internal error from FMOD sub-system.

This 5 audiclips where working perfectly in the last 2022.3.16 and below, they are old mp3 files that have no problem. Any ideas? Thank you.

Edit: I can confirm this does not happen with 2022.3.16, just imported with no problems.

I have same issue on Windows 11.
2022.3.16 and before: No error
2022.3.17: Some mp3 files have same error, these files are made by GarageBand on macOS.

I guess this update:
https://unity.com/releases/editor/whats-new/2022.3.17
- Editor: Updating fsbtool to match the current FMOD version. (UUM-32863)

Well it's nice to see I'm not alone with this. I work with Mac and my mp3 were created with Audacity. Maybe it's related to the way Mac generates mp3 files or the updated fsbtool might be responsible of the error. I tend to think of the second option.

Still happening in 2022.3.18. Uploaded a dangerous mp3 "ping" that crashes the system.

9597460--1360477--ping.mp3.zip (52.3 KB)

Finally, I decided to use ffmpeg to avoid the issue.
% ffmpeg -i foo.mp3 foo.wav

I guess sometimes the issue happens in Unity's history and everyone use the ffmpeg to avoid the issue. As result, the issue maybe low priority.

So I'll take this advice thank you, because it happens with five of my mp3 files that were working perfectly until 2022.3.16.

It's happening with some mp3 files and not others. All the mp3 files were created in the same way. Unity 2022.3.18f1

Edit: converting every sound into a wav first was the solution for me

1 Like

2022.3.17, play the attached mp3 file, system crash immediately.

9604763--1361786--music1.mp3.zip (776 KB)

Tested some tricks in 2022.3.17/18 to avoid the problem, negative results, the errors continue.

I have tried, delete the library folder, remove the mp3 file, regenerate the library folder, copy the mp3 file back. It can play the mp3 file without crash. ?? What the problem is?

It only happens with some mp3 files when upgrading the project to 2022.3.17/18. I have many mp3 but some of them were working fine until these versions. Don't know why, they are old mp3 files I have used in other projects with no problems, and until 2022.3.16 they were working fine.

I've been able to solve it by regenerating a new mp3 file from the original with Audacity. I can regenerate the 5 mp3 that give me problems and go to 2022.3.18, but as I said those mp3 are files that worked perfectly until 2022.3.16.

This issue continues in 2022.3.19f1. A workaround is, as ScottyDSB mentioned, importing it to Audacity, then exporting from Audacity to the location where it was again in the project. Overriding the original file worked for me.

The issue continues on Unity 6 with .mp3 and .wav

Unspecified error during import of AudioClip Assets/Audio/test.wav
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

File a bug! Unity6 is in preview mode.

Because a forum necro post is not a bug report, NO ACTION will be taken on this post.

If you have a bug, there is only one way to report it.

Help -> Report A Bug.

Report one bug at a time with all the expected supporting information attached.

Any other way is NOT a bug report and is NOT going to change anything.

1 Like

Rename the Audio file large name to smaller name, this issue will not happen again