Errors during XML parse: System.Threading.ThreadHelper:ThreadStart ()

Does anyone know why these warnings appear and how I can solve it, thank you very much.

Errors during XML parse:
System.Threading.ThreadHelper:ThreadStart ()
Additionally, the fallback loader failed to parse the XML.
System.Threading.ThreadHelper:ThreadStart ()
2 Likes

When does it happen?
Is it from your code or from the engine?
Does it give any issues?

I recently started getting these same 2 warnings, randomly, even when everything in the project is functioning correctly. It's never at the start of the project but after 10min or so of having the editor open. Which XML file is it talking about ? If somebody knows.

Im on a M1 Macbook running Unity Version 2022.3.20f1

We also started seeing these warnings some days ago. It seems something must have changed on Google's end when using sdkmanager.

I've been getting these warnings. Seems to happen when I have the project settings open. I'm on Unity 2022.2.24f1.

2 Likes


Hello @DevDunk , it happens to me in version 2022.3.20f up to 2022.3.24f that I have been testing. They seem to appear when in the editor, in Project Settings I simply move the cursor over the options. A priori it doesn't seem to cause any other problems, but I don't know if it affects anything.

I am having the same issue:

Errors during XML parse:
System.Threading.ThreadHelper:ThreadStart ()

It seems harmless, but I always get worried when the project shows a weird warning.

Started for me a few days ago, 2023.2.3f1

Same situation as @digipaul (I assume you mean 2022.3.24), also true for 2022.3.25.

I think I have the answer, at the beginning I also had the same problem, but I noticed that in the XR plug-in management section, I had activated both the google ARcore and the Oculus, because I am making an app for oculus I disabled google ARcore, and my problem was solved, I hope it is useful

3 Likes

Thank you, it worked for me too. I am developing with OpenXR for oculus metaquest 2.

If you are using xr just check and fix the issues which can be found by navigating the xr pannel in the player settings and check the pannels bellow the xr pannel

Same situation here, using 2022.3.22f1 and AR Core isn't selected :-/

I get the same warning starting from version 2022.3.23. Also from the same version I don't get android build when burst compilation is enabled. Every time I get build failed. Only up to version 2022.3.22 everything works fine. This is a problem on the Unity side.