Errors! Nooooooooooo! :(

Getting these errors… No idea what happened here. :frowning: I had double of a script, and deleted one because that was causing an error, but did not clear these…

So far my game only has scriptless models and terrian…

-----CompilerOutput:-stdout–exitcode: 255–compilationhadfailure: True–outfile: Temp/Assembly-UnityScript-firstpass.dll

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(37,39): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(38,39): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(39,34): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(40,24): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(41,24): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(42,24): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/AntialiasingAsPostEffect.js(47,30): BCE0017: The best overload for the method ‘PostEffectsBase.CheckSupport()’ is not compatible with the argument list ‘(boolean)’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(72,30): BCE0017: The best overload for the method ‘PostEffectsBase.CheckSupport()’ is not compatible with the argument list ‘(boolean)’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(76,31): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(77,37): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(78,36): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(79,41): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(80,53): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(81,43): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/BloomAndLensFlares.js(82,44): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/DepthOfField34.js(83,35): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/DepthOfField34.js(84,31): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/DepthOfField34.js(88,41): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/DepthOfField34.js(93,30): BCE0017: The best overload for the method ‘PostEffectsBase.CheckSupport()’ is not compatible with the argument list ‘(boolean)’.

Assets/Standard Assets/Image Effects (Pro Only)/GlobalFog.js(35,31): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/GlobalFog.js(40,30): BCE0017: The best overload for the method ‘PostEffectsBase.CheckSupport()’ is not compatible with the argument list ‘(boolean)’.

Assets/Standard Assets/Image Effects (Pro Only)/TiltShift.js(31,37): BCE0005: Unknown identifier: ‘CheckShaderAndCreateMaterial’.

Assets/Standard Assets/Image Effects (Pro Only)/TiltShift.js(36,30): BCE0017: The best overload for the method ‘PostEffectsBase.CheckSupport()’ is not compatible with the argument list ‘(boolean)’.

Some points:

  • No real question title
  • useless listing of 20+ similar error messages. One of each would be more than enough.
  • You probably deleted a file that was part of the standard assets and all those image effects needs something from that file. We don’t know what you’ve delete so we can’t reproduce this problem.
  • Don’t post multiple questions on the same issue

I suggest to reimport the image effects package:

Menu -> Assets -> Import Package -> Image Effects

If you don’t use the image effects or when you don’t have unity pro, just delete all the image effects since you can’t use them in the free version. That’s why there’s a “(Pro Only)” behind the package name.

I think that the feature that you are using is from Unity Pro. I’m guessing you are using Unity Basic. Remove or delete the ones that are from the feature of Unity Pro if you are using Unity Basic.