Everytime Unity Editor is launched. I am asked to Sign into your Unity Account

The check box “Remember Me” is turned on.

Sometimes I can launch Unity and it will sign me in automatically. Other times, it asks me to sign in consistently. It gets rather annoying having to sign in every time. Is there any reason why the sign in window is prompting for my email and password, even though “Remember me” is checked on?

I have 2 separate versions of Unity installed at the moment. Happens to both of them (version 5.1.3f1 and 5.2.1)

My Internet connection has been stable, with no disconnects.

So today, I closed all the instances, and re-opened Unity. And the sign in worked, I didn’t have to type anything. Which is great for now, but it doesn’t answer the question – why this is happening. I’ve seen single instances consistently prompt for a sign in as well, but it’s not happening at the moment. I’ll close this question, and pray the problem doesn’t come back.

I solve this problem in Unity 5.5:

The final solution is:

  1. Login again, and open the UnityEditor.
  2. Go to Help → Manage License.
  3. Click on “Activate New License” to reactivate Unity again.
  4. Close Unity and reopen it, check if it ask you to login in again.

why this problem happened to me, I updated my Unity and the login process bugged out. I have to reopen Unity and login again. But for some reason Unity didn’t activate properly.

I have noticed the same. I only use one Unity version at a time and i usually don’t open the editor multiple times. Yet i see the same behaviour.

Even i haven’t tried it myself it should be possible to pass the email and password as commandline arguments to Unity.

-username <username>
-password <password>

I have tried it, but it seems it doesn’t work. I passed my email address and my password as commandline arguments but Unity still asks for it at startup.

So either i did something wrong, or it doesn’t work for “normal mode” and it’s only used with the batchmode?!? So it seems there’s no solution yet (besides using things like AutoHotkey and write a “login” script)

Having same problem here too, but some times carefully exit Unity, and running it again does the trick. If its a glitch in the sign-up “remember me” uiswitch, then i hope they fix it soon.