Exclude skybox from Bloom Effect

I am wondering if its possible to exclude the skybox and fog from being effected by the Bloom and Lens Flare effect? The shader makes the objects in the scene look nice but it blows out the sky and the fog.

I guess you can’t since bloom and lens flare are post process effects applied to your entire image once it has been rendered. You would have to have two cams, one used to render the sky, the other to render the rest of the scene and composite them together.

As Pawscal said, try making 2 separate cameras to render the skybox/anything else. just put the new camera’s “Clear Flags” to be “Don’t Clear”.

You might set the Clear Flags value for the main camera to ‘Don’t Clear’ or ‘Depth Only’ to remove the skybox. You can then restore it via a separate camera by setting its culling mask to ‘Nothing’ and depth to a value below that of the main camera.

@ZiadJ @Pawscal @Whiteleaf @roger0

Hi everyone, I’m having a similar problem here… (sorry for reviving an old post)
I have tried the above methods but can’t seem to get this right…

What I want to achieve:

  • To have a few objects in the back, some UI elements on top of these, and apply a blur effect ONLY to the UI elements (the objects in the back must not be affected).

I have tried so many things, but until now I could only get the effect to affect everything, or only the back objects…
I’m using two cameras, one for the back objects (which are in their own layer), and one for the UI elements and blur effect.
I don’t need the Skybox so I’m putting both cameras’ Clear Flags as “Depth only”, and each one’s Culling Mask as the layer I want to be rendered (one for the UI elements, and another one for the back objects).
The back objects layer has a depth of -1, and the UI elements one has a depth of 1.
Both cameras are being rendered in the Display 1.

Any help would be appreciated!
Thank you in advance!!!