Export from Blender to Unity - Colliders

When i export object from Blender to Unity object’s collider looks weird. How do i get better collider to my object?

Unity’s MeshCollider component has a checkbox called Convex - if you uncheck that, it should match your mesh a lot better, but at the cost of it not being able to collide with other MeshColliders. This is done for performance reasons - a convex mesh is relatively easy to calculate, as it assumes there are no holes or concave features, whereas a concave mesh can have all kinds of weird geometry (like your shape from Blender) that would be far too CPU-heavy to calculate on the fly. Primitives will still collide with a non-convex mesh.

For this shape, if you need it to collide with other MeshColliders, you’d get the best results by following Hexagonius’s advice and using Unity primitives to create this object, setting them all as children of an empty root GameObject in the hierarchy.