Extremely Frustrated! How to stop Jaggered Edges ( OpenGL )Android Build?

I have a game which looks great on a web build, When I change to Android the edges of my models become extremely jaggered. It is not an anti aliasing problem, the model looks deformed. This seems to happen where models intersect each other.

I think it might have something to do with Generic OpenGL ES2.0. If I turn this on in my Graphics Emulation settings in Unity I get the same result as on the device.

The 1st image shows what my game looks like on the device, the second images (no emulation) shows what it should look like.

Thanks

Try this : make your active camera’s near clipping plane value bigger like 10.