[Face Capture]Connection issues

I’m glad to try the face capture package.But I met the connection issues.I have tried to delete the live capture rules.Then I have tried to turn off all firewalls.But it doesn’t work.The face capture app can display my computer name,but it can’t connect to it. The face capture app stuck in the “Trying to Connect” state.

By the way,when I install the live-capture package in the Unity Editor,I clicked the “Configure Firewall” button in the Connections window.But it still warned me that “The firewall is not configured optimally for Live Capture”.

IPhone 11 Pro Max
IPhone OS 13.4.1
Win10 Home 20H
GTX 1070
Unity 2020.3.1f1c1
Live Capture 1.0.1-pre.465
Face Capture 0.1(465)

Hope for answers,thanks!

I just installed the pre-525, the version the app (which I just installed as well) recommended. It also found my PC but would not connect. I clicked the "fix firewall" and after that it managed to connect. So maybe try the latest version?

I have not managed to get it to do anything after that yet! ;-)

[quote=“akent99”, post:3, topic: 847849]
I just installed the pre-525, the version the app (which I just installed as well) recommended. It also found my PC but would not connect. I clicked the “fix firewall” and after that it managed to connect. So maybe try the latest version?

I have not managed to get it to do anything after that yet! :wink:
[/quote]
As you say,I updated the package and app to the latest version(pre-525),but it didn’t work.I clicked the “Configure Firewall” button,it still warned me that “The firewall is not configured optimally for Live Capture.” Then I tried to connect the app to my computer,but failed.

So I tried to turn off all firewalls,failed again. it really confused me.

@ILLB

There is a known issue with the firewall configuration detection where the firewall rules are not correctly found by Live Capture. You can open your firewall to check if there is an inbound rule named "Unity {Version} Live Capture". If there is a rule, the configuration worked. If not, you can manually add the firewall rules as shown here: https://docs.unity.cn/Packages/com.unity.live-capture@1.0/manual/setup-network.html

Try manually entering the IP instead of using the automatic server discovery. Sometimes the client doesn't pick the right interface on the server to connect to when using the automatic server discovery, so that can help. Also try disabling unused or extra interfaces (VPNs, etc.) if that still doesn't work.

It confused me too.
I have tried setup projects both on windows PC and Mac, but my phone still can't connect to server.
And there is always warning about firewall config on win PC, but nothing on Mac.
Also, I have tried to set firewall rule manually and enter ip manually, but it doesn't work.
I spent a couple hours. Hope for answers,thanks!

I hate to ask a stupid question but where do you find the Live Capture package? I don't see it anywhere.
Thanks,
Jeff

never mind, just found it.

Okay, the live capture package is installed but I do not see the connection editor anywhere so that I can connect to the iPhone. The docs say it should be under the Window menu.
Jeff

Dang - you found it too quickly! ;-)

7385831--901451--upload_2021-8-3_10-11-10.png

After I install it, it does appear under Window menu for me

7385831--901454--upload_2021-8-3_10-11-51.png

7385831--901457--upload_2021-8-3_10-12-35.png

Thanks, found everything. Can't get it to work w/ the sample scene yet, but I'll keep trying.
Jeff

hmmm... I can see data streaming into the blend shapes from the iPhone app but nothing is being driven. So I'm missing a connection between the Actor face, the Face Mapper and the PreFab somewhere. Although it all looks good.

1 Like

I can connect with Virtual Camera App, but I cannot connect with Face Capture App... I don't if I got something wrong or the app got something wrong...

1 Like

same issue:
https://discussions.unity.com/t/871294

I don't use a wi-fi connection to my pc, I use an ethernet. I've gone through the steps listed here regardless but have not been able to assign a free port within the window for Live Capture in Unity.

Has anyone else not been able to choose any of the ports? It says all of them are being used and for me to choose a free one, yet none of them are free?

I've done all the firewall configuration so I'm not sure why I can't assign a port.